IBM’s customized ESXi 5.0 FAQ’s

Since the release of IBM’s customized ESXi 5.0, there’s been a number of queries on what it contains and how you use it to upgrade to vSphere 5.0.    One of my colleagues, Wayne Wigley in the US has compiled this useful FAQ, which I’ve published below:

Q)  When will vSphere 5 ESXi be available on an IBM USB Key?

A)  The IBM USB key pre-installed with ESXi 5.0 IBM customized image was made available on the 26th January, 2012.

Q)  When will the OEM custom hypervisor image for IBM systems be available on the VMware (IBM) portal?

A)   IBM has not negotiated to put the image on VMware’s website.  The code was posted on the IBM site (http://www-03.ibm.com/systems/x/os/vmware/esxi/index.html) on December 16, 2011

Q)  What will be the upgrade path for existing IBM 4.x ESXi USB key installations?

A)  A customer can download the new image from http://www-03.ibm.com/systems/x/os/vmware/esxi/ for free and apply to the existing key.

Q) How do you upgrade the IBM USB customised image to the IBM ESXi 5 image?

A) You can upgrade any IBM USB customized image release 4.1U1 and higher to the IBM ESXi 5 customized version using 2 methods.  The first method is using the ISO image.

While upgrading the image you will see the following screens.  Choose the Force Migrate option.

After selecting to Force Migrate you will be presented with the following screen

Press Enter to continue. Then you will be presented with the screen below

Choose (F11) to continue with the upgrade.

You can also use VMware Update Manager (VUM) as I previously documented here.

Q)  What will be the upgrade path for existing IBM 4.x ESXi USB key installations (key replacement or install new hypervisor code)?

A)  If a customer needs to replace a USB part they will get the same FRU part number back.  For example,  they will get 4.x for 4.x.  The ESXi software can be downloaded, so a customer can upgrade to the next level, but they will have to apply all patches again.

 

Q) What is the IBM roadmap for ESXi releases ?

A)  IBM is continues to refresh our roadmap with the latest VMware releases and the time to market for new code releases and patches to better align with VMware’s release dates.

Q) What are the CIM providers and drivers that are included in the IBM ESXi 5 customized Image that are not in the VMware image?

A)  These are:

IMM provider, version is 500-2ACE08AUS. Including concretejob, filetrans,fwupdate, immpassthru  (new)

CBB provider. version is 500-ESXI01ACN. Including hwckvm, smbios,pciinfo.

FUPB provider, version is  1.23-7.100

Emulex provider version is .3.4.19.1-01:

  • drivers: net-be2net-4.0.355.1-1OEM.500.0.0.406165
  • scsi-be2iscsi-4.0.317.1-1OEM.500.0.0.406165
  • scsi-lpfc820-8.2.2.105.36-1OEM.500.0.0.406165
  • ima-be2iscsi-4.0.317.1-1OEM.500.0.0.406165

Brocade provider version is 3.0.0.0-0:

  • drivers:  net-bna-3.0.0.0-1OEM.500.0.0.406165.x86_64
  • scsi-bfa-3.0.0.0-1OEM.500.0.0.406165.x86_64

Qlogic provider version is 1.3.8-381646:

  • driver:scsi-qla4xxx-624.01.32-1vmw.500.0.0.406165
  • ima-qla4xxx-500.2.01.16
  • net-qlge-1.0.0.47-1vmw.500.0.0.406165

LSI provider version is 500.04.V0.24-261033

  •    LSI facade provider version is 500-1.00.20111020
  •    driver: scsi-megaraid-sas-5.34-1vmw.500.0.0.406165

IBM OEM vib version is 2.0-2

* * *

If you have any other queries on IBM’s customized ESXi 5.0,  please let me know and I’ll try to get them answered for you.

Darryl

Advertisements
  1. #1 by Eric on February 21, 2012 - 2:39 pm

    Can the custom IBM version be modified to include 3rd party products such as EMC PP and Cisco 1000v?

    • #2 by Darryl Miles on February 21, 2012 - 3:31 pm

      Hi Eric, as the IBM customized ESXi release doesn’t of course limit the core VMware functions, I don’t believe there is any issue with also including these third party products too. Much like also including IBM’s new 5000v virtual switch. Darryl

  2. #3 by Terry on March 29, 2012 - 7:55 am

    I would like to update the media this is based on to the latest version of ESXi but I can’t work out how to do that with the supplied ISO; is there an easy way to obtain the zip version to add into image builder or do we have to hunt out the seperate vibs ourselves

    • #4 by Darryl Miles on March 29, 2012 - 12:01 pm

      Hi Terry,

      Great question, let me see if I can find an answer for you and update this blog too with any info.

      Darryl

  3. #5 by Florian on April 3, 2012 - 7:19 pm

    Hi Darryl,

    I tried the ESXi 5 U1 ISO on an IBM x3550 M2. Surprisingly the LSI Provider for Serveraid Controllers was not installed even though you listed it as included. I was able to install it manually from the LSI bundle “VMW-ESX-5.0.0-LSIProvider-500.04.V0.24-261033-offline_bundle-456178” – afterwards it appeard in the “software components” and under “Storage” the RAID controller specifics are now visible.

    • #6 by Darryl Miles on April 3, 2012 - 8:14 pm

      Thanks for the info, I’ll pass this onto our virtualization / system x team. Were you using IBM’s customised vSphere 5.0 first, or did you use VMware’s ESXi 5 U1? Darryl

      • #7 by caraboy on April 13, 2012 - 2:36 am

        Hello, I am having the exact same issue with the LSIProvider (not included in the 5 U1 iso), on IBM x3550 M3.

        I just booted the server with the new image, downloaded directly from IBM. Megaraid storage manager fails to discover the board because of this.

        I will try and find the provider for my m1015. Also, I could not find info on how to update the current install, so I had to start with a clean new image. 🙂

        Regards,
        Alexandru

      • #8 by Darryl Miles on April 13, 2012 - 12:39 pm

        Hi Alexandru,

        Thanks for the info. I’ve passed this feedback onto the IBM customized ESXi development team.

        Darryl

  4. #9 by Florian on April 4, 2012 - 9:05 pm

    I’m sorry for the misunderstanding, of cause I tried the IBM customised image.

  5. #10 by caraboy on April 15, 2012 - 1:44 am

    Thanks Darryl.

    I managed to install the LSIProvider, and started up MSM from a client pc (the server was discoverable after 10 minutes).

    But Storage Manager it`s extremely slow to work with, not only in connects in 2 minutes, but after that, it`s impossible to create a virtual drive. You set up the drive, then the interface freezes. You have to reconnect to view the changes. 😦

    Too bad.

    Have a nice day,
    Alexandru

    • #11 by Florian on April 26, 2012 - 10:44 pm

      Hi Alexandru,

      agreed. It’s incredible slow here too. Not usable imo.

      • #12 by caraboy on May 1, 2012 - 11:00 pm

        Hi Florian,

        I just removed the LSI Provider, as you said, it`s not usable, and for an unknown reason occasionally I also lose sensor information (unknown at every read).

        Let`s see how the server behaves without it. As for the RAID status, I`m better of restarring the server from time to time to check the array.

        Regards,
        Alexandru

  6. #13 by jlux on May 3, 2012 - 6:10 pm

    Just wanted to let everyone know about this. This install image caused a purple screen on IBM hardware x blades with H chassis and VFSM and we had to revert back to standard image. IBM couldn’t find a solution.

    • #14 by Terry on May 4, 2012 - 7:04 am

      Interesting; what do you use for CNA’s? We have Qlogics on ours with 4001 switches and have had fairly stable running so far. That said we have had two cases of psod’s right at the completion of the install that I could never explain.

  7. #15 by David on May 9, 2012 - 3:03 pm

    Can regular VMware issued security patches be applied to hosts using the customised image or are we required to wait for IBM to release an update to match?

    • #16 by Darryl Miles on May 10, 2012 - 12:51 am

      Hi David,

      Let me find out if there is any official policy from IBM. I’d assume there wouldn’t be any issues in a customer applying security patches to IBM’s customized image (since that image is simply management enhancements/drivers to VMware’s ESXi image).

      Darryl

  8. #17 by Dr.Sigmund on May 27, 2012 - 8:14 pm

    ESXi 5.0 U1 introduces an issue which is a show-stopper for many use cases: VM autostartup stops working on Free Hypervisor version. See, for example, this link: http://blogs.vmware.com/vsphere/2012/03/free-esxi-hypervisor-auto-start-breaks-with-50-update-1.html

    Does IBM-provided version also has this problem?

    • #18 by Darryl Miles on May 29, 2012 - 12:00 pm

      Let me see if I can get an answer from our VMware team. Darryl

  9. #19 by lakernetman on June 2, 2012 - 3:07 am

    Last fall I purchased two physical servers, vCenter Server 5 Essentials, vSphere 5 Essentials Plus and two USB hypervisor keys imaged with ESXi 4.1.
    I received the USB keys from IBM, but the software support is licensed through VMware.
    I would like to upgrade the hypervisors to ESXi 5, but I am confused on a few points. Are my current images running the customized IBM release? Do I go to IBM or VMware for new images? Where are the downloads? Do I have to replace the keys, or can I just replace the image on them? Who provides the instructions in the latter case? Lastly, who is providing the “license”, IBM or VMware?

    Thanks in advance,
    Laker

    • #20 by Darryl Miles on June 2, 2012 - 9:31 pm

      Hi Laker,

      I’d expect if you ordered the USB hypervisor keys via IBM, they’ll be IBM’s customized ESX release. Regardless of whether you buy vSphere 5 via IBM or VMware, you can use IBM’s customized ESXi 5.0. The benefits of using it are essentially that it “eenable on-line platform management, including updating and configuring firmware, platform diagnostics, and enhanced hardware alerts”. See http://www-03.ibm.com/systems/x/os/vmware/esxi/. If the key’s have space, you could upgrade the software as detailed here https://darrylmiles.wordpress.com/2012/02/20/ibms-cusomized-esxi-5-0-faqs/. I’d speak to your IBM representative on vSphere 5 upgrade pricing. I hope this info is of help.

  10. #21 by Steph on June 5, 2012 - 6:38 am

    Is there any supported path to upgrade an esxi 4U1 or higher VMware image to the latest esxi 5 IBM Customised image ? What about customers who have several esxi VMware images installed in production and want to manage their IBM Servers with IVP or ISD ? Are IBM Providers could be installed separately on an esxi VMware image ?

    • #22 by Darryl Miles on June 5, 2012 - 7:38 am

      Hello,
      You simply follow VMware’s upgrade process from VMware 4U1 to 5 but use IBM’s customized ESXi instead. The easiest way I’ve found to do this is via VMware Update manager as outlined here. You can get hardware alerts from a range of different ESX versions with ISD. Yes, IBM providers would be installed separately if you didn’t want to use IBM’s customized version.

  11. #23 by Florian on October 10, 2012 - 8:07 pm

    When will the vSphere 5.1 customized images be available?

  12. #24 by John Call on December 17, 2012 - 4:05 pm

    Darryl, I recently saw a posting to the IBM support site described as “VMware vSphere ESXi 5.0 with IBM Customization Patch 4”. This software depot (ZIP) patch has corrected some issues I’ve had updating UEFI, IMM, and Emulex firmware. When will IBM include this software depot into the customized ESXi / vSphere Hypervisor ISO? Having two steps: install from ISO, then patch, is tedious.

  13. #26 by sherpard on July 28, 2013 - 2:28 am

    if i buy the IBM USB Key for VMware ESXi 5.0 , do i need to purchase any license from VMware ? what are the limitations of this products as far as the licensing is concerned. On IBM site there insnt much information regarding licensing. .

    • #27 by Darryl Miles on July 28, 2013 - 7:36 am

      Contact your local STG sales rep for clarification. Essentially you can buy VMware licenses from IBM directly or from other resellers.

  14. #28 by Shaun on January 24, 2014 - 2:40 am

    is it possible to load esxi 5.5 IBM customized iso in to Flex? 5.1 U1 worked ok, 5.5 throws an error invalid image.
    thanks.

    • #29 by Darryl Miles on February 6, 2014 - 1:52 pm

      Hi Shaun, sorry but I’m not working with the latest releases of ESXi and VMware (as I’m in a new role). Please contact your friendly IBM/Lenovo SME for assistance. Darryl

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: